odbc-rails gem installation problem

Hello...

I install the odbc-rails gem by running:

gem install -r odbc-rails --include-dependencies

Then I add require 'odbc_adapter' to my config/environment.rb

When I start the server I get this beauty....

C:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.15.5/lib/active_record/
connection_adapters/abstract/connection_specification.rb:34:
uninitialized class variable @@allow_concurrency in ActiveRecord::Base
(NameError)

        from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `gem_original_require'

        from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `require'

        from C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/
active_support/dependencies.rb:495:in `require'

        from C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/
active_support/dependencies.rb:342:in `new_constants_in'

        from C:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/
active_support/dependencies.rb:495:in `require'

        from C:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.15.5/lib/
active_record/connection_adapters/abstract_adapter.rb:10

        from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `gem_original_require'

        from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `require'

         ... 27 levels...

        from C:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.5/lib/commands/
server.rb:39

        from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `gem_original_require'

        from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `require'

        from script/server:3

Appreciate anyones help.

Thanks,

GPB