Not able to successfully create new Rails application.

When I try to create basic skeleton of Rails application using:

rails MyApp

is generating lot of errors as soon as it starts:

run bundle install.

It installs few things here but displaying errors even when Internet
Connection is ON. Sometimes the errors are of SSL and sometime of Coffee

Attached is the image.


to create new app in rails command is => rails new YOUR_APP

are you using windows 7?

Yes I am using Windows 7.

i will advice you to use Ubuntu with wubi installer
because rails did not provide that support in windows which it provide in Mac or Linux ( Linux based Ubuntu 12.04 )

At present this is not possible. Suggest ways to make it work on Windows

which tutorial are you using or book?

Head First Rails

which version of rails are you using?


Hi Rohit,

rails new demo

*(It will create a new demo application)

rails new demo -d=mysql (create a rails new application with default mysql database)



I even tried:

rails new demo

but it crashes somewhere or the other in

run bundle install

Some have had success with rails on windows using but I believe it will never be as
comfortable an experience as using linux.

I would advise against using wubi however, I have not found it
reliable. Instead go for a true dual boot setup with, for example,
Ubuntu. If that is really not possible then a Ubuntu virtual machine
running in vmware or virtualbox in windows can work well.

Do not reject these options because of the learning curve with linux,
in the long run it will save time.


Ok. I have a Fedora 16 CD. Will install it. I think it doesn't make much
difference between Ruby in Fedora 16 and Ruby in Fedora 17?

BTW, RailsInstaller worked.

Sorry, can't comment on Fedora. I'm a Ubuntu man myself. Make sure
you use rvm to manage ruby and gems. This looks as if it might be a
good start



Thanks for the same.