Newrelic doesn't log in daemon mode

Hello All,

I have integrated Newrelic with my rails application.

It is working fine in “rails s -e production” mode, but not in “rails s -e production -d” mode.

How can I fix the problem?

Thanks,

Avi

Have you checked NewRelic support?

What server are you running? What versions of Ruby/Rails?

Do you see anything related to newrelic in your log at startup?

Hello,

I am using “Thin server” in production.

Ruby - 1.9.3

Rails - 3.2.8

If I run in only production mode, then it starts logging. it is not working in rails s -e production -d mode.

Nothing on startup.

Is the log/production.log not showing anything?

There's a known similar problem with Puma that I ran into -- see this
support entry: https://docs.newrelic.com/docs/ruby/puma#daemonizing

WAG: I don't use Thin but you might try setting ` --servers 1` and see
if that "fixes" it. Otherwise, open a ticket with newrelic. :slight_smile:

(Also, your Rails version has security issues; you should upgrade.)

HTH,

Its working fine now. We have changed from thin to nginx + passenger.

Thanks for helping.