Need your advice - after Locomotive and MAMP

Hi guys, could you give me some advice here?
I've been programming in RoR for some time. I made 4 programs that are
used by some people, and I used Locomotive, MAMP and Textmate to
develop them on a Mac. Worked like a charm... until today!
I wanted to install Widgets (Tabnav seemed great) and suddenly nothing
works anymore. I get

ActionView::TemplateError (wrong number of arguments (4 for 2)) in

when I start up a program.

Obviously, something else was installed as well, but what? And how to
deal with it?

Now what is the best thing to do? I know Locomotive is no longer
updated/supported, so maybe I should use something else to develop in,
but at the same time I want to be able to use what I have made so far.
Is Aptana ok? But how to migrate then? (I've tried to migrate to
Aptana once before, but ended up going back, because I found it rather

All advice is greatly appreciated.

hey Rudy,
maybe tabnav is monkey patching something that has changed quite a bit since the version you installed was last modified. I googled around and discovered tabnav is now part of rails widgets. Is that what you installed.

It doesn’t look like rails widgets has been updated for rails 2.2, but maybe trying this version out is a next step

Locomotive still works fine for me.


Thanks for the reply, Alan. That was indeed what I installed.
Everything is just broke now. Bit of a disaster, really. Would
reinstalling MAMP and Locomotive do any good? Or uninstalling the
tabnav-widget - if possible?
I really don't know what the best road to follow is at the moment -
looks more like a desert to me now. :frowning:

Any suggestions?


I would uninstall rails widget and find something other way to implement tabs.

Hi Alan,

just to let you and others know: the culprit was the widgetsfolder in
the vendor plugin folder. After removing that everything was fine
again. Don't know why, but I SURE will not use this tabnav or widget
thing again - certainly not as long as it stays available only through
git. I don't like that at all.
Thanks for the suggestions anyway.