# Need security patches

**URL:** <https://discuss.rubyonrails.org/t/need-security-patches/59437>\
**Category:** rubyonrails-talk\
**Created:** [June 13, 2011, 7:05am UTC](https://discuss.rubyonrails.org/t/need-security-patches/59437 "2011-06-13T07:05:27Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rafi\_A](https://avatars.discourse-cdn.com/v4/letter/r/dec6dc/32.png) [@Rafi\_A](https://discuss.rubyonrails.org/u/Rafi_A)\
**Post date:** [June 13, 2011, 7:05am UTC](https://discuss.rubyonrails.org/t/need-security-patches/59437/1 "2011-06-13T07:05:27Z")

</div>

Hi All, I am using rails2.3.4 version ruby version 1.8.7 for my product.My client suggest me to apply if any security patches (security needs to be fixed in rails 2.3.4 & ruby 1.8.7) available. I dont know where and how should i find it.Please suggest me an idea or anyone knows any security patches for the same.

---

<div class="post-metadata">

**Author:** ![Colin\_Law1](https://avatars.discourse-cdn.com/v4/letter/c/91b2a8/32.png) [@Colin\_Law1](https://discuss.rubyonrails.org/u/Colin_Law1)\
**Post date:** [June 13, 2011, 7:59am UTC](https://discuss.rubyonrails.org/t/need-security-patches/59437/2 "2011-06-13T07:59:40Z")

</div>

You should upgrade to the latest 2.3.x version of Rails. Or to version 3 if you wish but that is more work. Make sure you have full automated test coverage first so that you can be sure the upgrade has not broken anything.

Colin
