mysql error on brand new application with one empty controller

I just purchased the rails space book, and I'm walking through. All I
did so far was create the application, and the controller with three
empty actions. When I try to navigate to any of them I get the
following error:
Mysql::Error in SiteController#index

#28000Access denied for user 'root'@'localhost' (using password: NO)

I even went into the database yml file and put in the correct db
password etc. I opened up another rails project I created and it
works fine. I deleted the project and recreated it, and I get the
same error.

I created the project using rails rails_space
Then the controller using script/generate controller site index help
about

What am I supposed to do with this?

Yes, once on the original application, then again when I created it
the second time.

I'm working in the development environment. I even logged in using
Mysql Administrator just to make sure it was working. I logged in and
created the database.

When I try and stop, then start the server I get some bad errors. I'm
going to try reinstalling mysql and see if that helps.

Ok, even after reinstalling, and restarting the computer I still get
the mysql error. The service is running, and I'm positive I have the
correct password in the yml file. Also, there is absolutely 0 sql in
this application so far, only an empty controller.