Is Rails 2.0 built on Ruby 2.0?

It uses Ruby 1.8.4+

Hi Michael, you must keep in mind that Ruby and Rails are two different projects. Thus, the version numbers between the two projects will not be in sync for the most part. Futhermore, Rails is dependent on a stable Ruby release to base their Rail’s release(s) on. At this time, Ruby 1.8.4 - 1.8.6 are the production release(s) of Ruby compatible with Rails 1.2.3. Last but not least, the Rails core is constantly working Ruby core to ensure synergy between the two projects.

Good luck,

-Conrad