interesting find: multiple file uploads stopped on Linux

Hi,

I came across something very interesting. I use attachment_fu for file
uploads and mongrel_cluster for scalability. Together they should
allow me to perform multiple (concurrent) file uploads. This does work
with uploads started on Windows, but on Linux something strange
happens: the upload started on Linux hangs.

So, if you start an upload from a Linux machine, and then start an
upload from a Windows machine, the Windows upload will go through but
the Linux upload will cause the browser to time out. If you start
multiple uploads from a Linux machine, they will both fail. If you
attempt multiple uploads from a Windows machine (or 2 different
Windows machines), they all work!

I tried many combinations: different Windows, Linux and Solaris
machines with different browsers (ie, mozilla, firefox, sea-monkey).
You can trace the upload by looking at the /tmp folder of the web
server. When a Windows upload starts, you can see a CGIXXXX-0 file
growing in the /tmp folder. When the Linux upload starts, you can see
a second CGIXXXX-0 file in the /tmp folder. After 1-2 seconds, the
temp file corresponding to the Linux upload stops growing (while the
Windows upload file continues to grow).

Does anyone know why this happens?

Thanks,
Tiberiu

You could try it with just one mongrel and see if that helps.

False alarm. For some reason the IS&T group at work is somehow capping
uploads. I tried it from home from a Linux machine and it works.

Tiberiu