Installed RMagick and ImageMagick, now Chronic is given errors

I'm stuck. I'm relatively new to Rails and haven't had to troubleshoot "rails weirdness" before.

I've been using Chronic for a while now without any problems. But, I just installed ImageMagick, RMagick, and Gruff. One of those required me to run "gem update -- system". Since then, I've been getting this error:

MissingSourceFile (no such file to load -- chronic)

and this error:

Gem::Exception in controller#action can't activate rubyforge (>= 1.0.0), already activated rubyforge-0.4.4]

I tried uninstalling and then reinstalling the Chronic gem, but there is no change.

Any tips on where to go from here?

Thank you!

I'm stuck. I'm relatively new to Rails and haven't had to troubleshoot "rails weirdness" before.

I've been using Chronic for a while now without any problems. But, I just installed ImageMagick, RMagick, and Gruff. One of those required me to run "gem update -- system". Since then, I've been getting this error:

Sounds like something is explicitly requiring a fixed version of a gem

Fred

I'm stuck. I'm relatively new to Rails and haven't had to troubleshoot "rails weirdness" before.

I've been using Chronic for a while now without any problems. But, I just installed ImageMagick, RMagick, and Gruff. One of those required me to run "gem update -- system". Since then, I've been getting this error:

MissingSourceFile (no such file to load -- chronic)

and this error:

Gem::Exception in controller#action can't activate rubyforge (>= 1.0.0), already activated rubyforge-0.4.4]

I tried uninstalling and then reinstalling the Chronic gem, but there is no change.

Any tips on where to go from here?