install plugin from zip file

i have been trying to install the geokit plugin. for some reason
script/plugin install svn://rubyforge.org/var/svn/geokit/trunk
isn't working for me. i downloaded it as a zip file from
http://rubyforge.org/frs/?group_id=3031
but don't know what to do now.

i tried extracting it and typing "ruby script/plugin install c:
\path_to_geokit_folder" from my rails app but that didn't work either.
how do i get this installed into my rails app?