in a rails3 - rspec then require 'authlogic/test_case' and now I broke stuff?

I’m a newb here and probably shouldn’t be using Rails3 yet to start with, but for some reason I was feeling adventurous.

I’m also learning to use rspec along the way and things ‘were’ working out with my ‘rake spec’ until I tried to follow some examples for test Authlogic with rspec.

I ‘think’ what started the problems was when I added at the top of a controller test:

require ‘authlogic/test_case’

After doing that, I seemed to have to re-run ‘bundle install’ (or maybe that was triggered because I touched the Gemfile, even though I ended up not adding changes to it.)

I was prompted with:

git://github.com/odorcicd/authlogic.git (at rails3) is not checked out. Please run bundle install
/Users/rick/projects/rails/sillymeters/Rakefile:4:in `require’

(See full trace by running task with --trace)

I rand bundle install, but now every time I try to run “rake spec” I end up with the following error:

rake spec
(in /Users/rick/projects/rails/sillymeters)

/Users/rick/.rvm/rubies/ruby-1.9.2-preview3/bin/ruby -S bundle exec /Users/rick/.rvm/rubies/ruby-1.9.2-preview3/bin/ruby -Ilib -Ispec “./spec/models/meter_spec.rb” “./spec/models/user_spec.rb”
/Users/rick/.rvm/gems/ruby-1.9.2-preview3/gems/rspec-core-2.0.0.beta.20/lib/rspec/core/backward_compatibility.rb:20:in `const_missing’: uninitialized constant ActionMailer::TestCase::Behavior (NameError)

from /Users/rick/.rvm/gems/ruby-1.9.2-preview3/gems/rspec-expectations-2.0.0.beta.20/lib/rspec/expectations/backward_compatibility.rb:6:in `const_missing'
from /Users/rick/.rvm/gems/ruby-1.9.2-preview3/gems/rspec-rails-2.0.0.beta.20/lib/rspec/rails/example/mailer_example_group.rb:9:in `<module:MailerExampleGroup>'

from /Users/rick/.rvm/gems/ruby-1.9.2-preview3/gems/rspec-rails-2.0.0.beta.20/lib/rspec/rails/example/mailer_example_group.rb:3:in `<module:Rails>'
from /Users/rick/.rvm/gems/ruby-1.9.2-preview3/gems/rspec-rails-2.0.0.beta.20/lib/rspec/rails/example/mailer_example_group.rb:2:in `<top (required)>'

from /Users/rick/.rvm/gems/ruby-1.9.2-preview3/gems/rspec-rails-2.0.0.beta.20/lib/rspec/rails/example.rb:6:in `<top (required)>'
from /Users/rick/.rvm/gems/ruby-1.9.2-preview3/gems/rspec-rails-2.0.0.beta.20/lib/rspec/rails.rb:10:in `<top (required)>'

from /Users/rick/projects/rails/sillymeters/spec/spec_helper.rb:5:in `<top (required)>'
from ./spec/models/meter_spec.rb:1:in `require'
from ./spec/models/meter_spec.rb:1:in `<main>'

I don’t know what went wrong? I even removed the test file that had “require ‘authlogic/test_case’” but now I’m still getting the error.
Again, things were working ok until I had to do ‘bundle install’ again

Interestingly I updated my rails version to rails3.0.0 from the 3.0.0.beta and now things are working again. Guess I’ll consider the problem solved for now.