I'm restarting to work with ruby on rails, but having configurations problems

I have the Shovell source code from the book Simply Rails 2, but I'm
having problems running it.

<pre>"Getting started
Here’s how to get rolling:

   1.
      Create your databases and edit config/database.yml

      Rails needs to know your login and password.
   2.
      Use script/generate to create your models and controllers

      To see all available options, run it without parameters.
   3.
      Set up a default route and remove or rename this file

      Routes are set up in config/routes.rb."</pre>

I took step 1, then since the models and controllers are already
generated for a source code that already exists, I skipped step 2 and
since a default route is already set for a source code that already
exists, I skipped step 3.

My config/roubes.rb has map.root :controller => "stories", but
http://localhost:3000/ still doesn't load the stories controller
index. Why?

I do not follow that book although it is updated for Rails 2.0.
Make sure you have map.resources :stories on routes,rb

I hadn't deleted public/index.html, but now I'm getting the error
message http://pastie.org/631341 How to solve?

After deleting public/index.html, I renamed application.rb to
application_controller.rb, then used rake to migrate my data with rake
db:migrated and it worked!

http://lmgtfy.com/?q=uninitialized+constant+ApplicationController

This code must be from before 2.3… you need to update it:

:; rake rails:update

Or, you can rename the controllers/application.rb file to controllers/application_controller.rb - but you’re better off running the command. Depending on how old the code is, you might create a whole new rails app, then copy your code to it or replace config files with the new ones and create any missing folders.

Lots of folks went through this upgrading to 2.3 or 2.3.2… google it a bit.

Richard

Try the first link, you might read up on