I got error xmlrpc-0.3.0 requires ruby version >= 2.3

Hi

I got error xmlrpc-0.3.0 requires ruby version >= 2.3 when i deploy to heroku . what should I do ?

Thank you

What is your Ruby version? Based on that error you need to have the version that required for that Gem. So either you upgrade your ruby version or downgrade the gem that requiring the specific version of ruby.

Thank you, I got finished about it.

Great! So, how did you solved it?

Hi Edsil, I have the same issue as Edsil and it is because of the Ruby version running on Heroku. Curious thing is that xmlrpc-0.3.0 is not a gem in my gemfile (pasted below) so I’m not sure how to downgrade the gem and I can’t upgrade the version of Ruby on Heroku (to my knowledge). Any ideas?

— GEM FILE —

source ‘https://rubygems.org

gem ‘rails’, ‘5.0.0.1’

gem ‘puma’, ‘3.4.0’

gem ‘sass-rails’, ‘5.0.6’

gem ‘uglifier’, ‘3.0.0’

gem ‘coffee-rails’, ‘4.2.1’

gem ‘jquery-rails’, ‘4.1.1’

gem ‘turbolinks’, ‘5.0.1’

gem ‘jbuilder’, ‘2.4.1’

gem ‘bootstrap-sass’, ‘3.3.6’

gem ‘carrierwave’, ‘0.11.2’

gem ‘mini_magick’, ‘4.5.1’

gem ‘fog’, ‘1.38.0’

gem ‘bcrypt’, ‘3.1.11’

gem ‘faker’, ‘1.6.3’

gem ‘will_paginate’, ‘3.1.0’

gem ‘bootstrap-will_paginate’, ‘0.0.10’

group :development, :test do

gem ‘sqlite3’, ‘1.3.11’

gem ‘byebug’, ‘9.0.0’, platform: :mri

end

group :development do

gem ‘web-console’, ‘3.1.1’

gem ‘listen’, ‘3.0.8’

gem ‘spring’, ‘1.7.2’

gem ‘spring-watcher-listen’, ‘2.0.0’

end

group :test do

gem ‘rails-controller-testing’, ‘0.1.1’

gem ‘minitest-reporters’, ‘1.1.9’

gem ‘guard’, ‘2.13.0’

gem ‘guard-minitest’, ‘2.4.4’

end

group :production do

gem ‘pg’, ‘0.18.4’

end

Windows does not include zoneinfo files, so bundle the tzinfo-data gem

gem ‘tzinfo-data’, platforms: [:mingw, :mswin, :x64_mingw, :jruby]

Hi Edsil, I have the same issue as Edsil and it is because of the Ruby version running on Heroku. Curious thing is that xmlrpc-0.3.0 is not a gem in my gemfile (pasted below) so I'm not sure how to downgrade the gem and I can't upgrade the version of Ruby on Heroku (to my knowledge). Any ideas?

It's probably a dependency of one of your dependencies (you can see these in your Gemfile.lock).

Heroku should pick the ruby version specified in either you Gemfile or your .ruby-version file. Amy relatively recent version of ruby should be absolutely fine (see https://devcenter.heroku.com/articles/ruby-support#ruby-versions for their supported version policy)

Fred

Frederick is correct, it is a dependency.

Thanks Edsil, Frederick. How did you solve it? Is it as simple as specifying a Ruby version >= 2.3 in your gemfile?

I noticed from the Heroku doco the default ruby version if none is specified in the gemfile is MRI 2.3.4

Hi Simon, have you tried specifying Ruby version on your Gemfile?

e.g

source "[https://rubygems.org](https://rubygems.org)"
ruby "2.4.1"

Indeed, specifying the Ruby version in the gemfile worked. Thanks all for your help.

Great!