I can't seem to make the jump from 1.1.6 to 1.2.3

Not much in the way of errors except for this one which doesn't make
sense to me...

Message
undefined method `password' for #
Location
http://localhost:3000/
Action
login
Controller
login
Query

Method
GET
SSL
false
Agent
Mozilla/5.0 (X11; U; Linux i686;
en-US; rv:1.8.0.10) Gecko/20070313
Fedora/1.5.0.10-5.fc6
Firefox/1.5.0.10 pango-text
Backtrace
On line #15 of app/views/login/login.rhtml 12: 13: User: 14: <%=
text_field("user", "login") %> 15: <%= password_field("user",
"password") %>

But I do have 'attr_accessor :password' in user.rb and it has worked
through 1.1.6 but not the jump to 1.2.3

Did I miss something somewhere?

OK - my real problem is routes...I commented out the line that was
giving me that error.

routes.rb (same as 1.1.6 - comments removed)
  map.connect '', :controller => "login", :action => 'login'
  map.connect ':controller/service.wsdl', :action => 'wsdl'
  map.connect ':controller/:action/:id'

My error...

$ script/server
=> Booting WEBrick...
=> Rails application started on http://0.0.0.0:3000
=> Ctrl-C to shutdown server; call with --help for options
[2007-04-11 15:11:56] INFO WEBrick 1.3.1
[2007-04-11 15:11:56] INFO ruby 1.8.5 (2007-03-13) [i386-linux]
[2007-04-11 15:11:56] INFO WEBrick::HTTPServer#start: pid=20616
port=3000
#<NameError: cannot remove Object::Entry>
["/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:422:in `remove_const'",
**** much clippage here ****
"/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'", "script/server:3"]
[2007-04-11 15:12:00] ERROR `/' not found.
127.0.0.1 - - [11/Apr/2007:15:12:00 MST] "GET / HTTP/1.1" 404 270

It all seems right to me but it doesn't work.

Solved this - for posterity...

#<NameError: cannot remove Object::Entry>

This was the significant error. It turned out that my problem was caused
by ruby-ldap package that I had installed and it turned out that all I
needed to do was to comment out these lines...

include LDAP

of course it took a long time to figure that out ;-(

Craig