How to start the ferret server in the production environment?

I have developed a rails app which used the ferret and acts_as_ferret plugin,but I never deployed a rails application,I wonder in the production environment,is it as easy as it is in the development environment?just connect the server with ssh and type “script/ferret_server -e production start”?

Thanks.

I’m using engineyard cloud computing service,as I expected before,I am facing some problems.After running the start command,the ferret_server doesn’t seems to start,cause when I stop the ferret_server it says"ferret_server doesn’t appear to be running.",and in the ferret_server.log,it shows “Cannot assign request address - bind(2)”.What can I do now?please help,thanks a lot.

So either you're trying to use a privileged port as a non-privileged
user, or that port's already being used by some other process.

If you have sudo rights, you can try starting ferret_server as root;
if that fails, the problem is the second one -- find a different port to
run on and configure appropriately.

Thank you for your reply.
I have tried to change the port number in config/ferret_server.yml
from 9010(the default) to another number(18275,a random number),and I
run:
"sudo ruby script/ferret_server -e production -R [rails_root]
start" ,and the problem is the same.
When the port number is 9010,I tried running the command with sudo
access,it's still this problem.
The faqs on the engineyard website says "Via sudo you have complete
control over your instances.We have sudo configured so that the user
you setup has access to sudo without a password being required" as
well.
I don't know what to do again.
Could you give me some other advice?Thanks in advance.

Hoo~~Ray!!!
The problem has been solved!
could someone tell me why I have to write ferret_server.yml like this:
..... production:
host: 127.0.0.1
....
neither
..
production:
host: localhost
..
nor
...
production:
host: [the IP of my instance]
... why?

It seems that I have make a stupid mistake...and this mistake takes me
about 10 days to find the answer...
During finding how to solve the problem,I learned something about the
port of amazon computing service,see here:
https://cloud-support.engineyard.com/discussions/problems/44-firewalled-ports
Before setting the host to 127.0.0.1,I tried this method,but it
doesn't work...may be this will be useful for somebody,so I put the
link above.