How to get fleximage plugin work on edge?

Hi all!

I have developed an application during the last month as a personal
rails learning project (I'm from .NET world). Now I want to make the
site public. The application is developed using edge rails because I
need the I18n features. The thing is that the fleximage plugin stopped
working when I moved to edge. Any help how to fix this would be highly
appreciated.

This is the log messages when calling the image show action:

NoMethodError (undefined method `compile' for #<Fleximage::View:
0xb5fd9688>):
    /vendor/rails/actionpack/lib/action_view/template_handler.rb:11:in
`call'
    /vendor/rails/actionpack/lib/action_view/renderable.rb:22:in
`_unmemoized_compiled_source'
    /vendor/rails/activesupport/lib/active_support/memoizable.rb:53:in
`compiled_source'
    /vendor/rails/activesupport/lib/active_support/memoizable.rb:21:in
`__send__'
    /vendor/rails/activesupport/lib/active_support/memoizable.rb:21:in
`memoize_all'
    /vendor/rails/activesupport/lib/active_support/memoizable.rb:18:in
`each'
    /vendor/rails/activesupport/lib/active_support/memoizable.rb:18:in
`memoize_all'
    /vendor/rails/activesupport/lib/active_support/memoizable.rb:13:in
`freeze'
    /vendor/rails/activesupport/lib/active_support/memoizable.rb:66:in
`_pick_template'
    /vendor/rails/actionpack/lib/action_view/base.rb:351:in
`_exempt_from_layout?'
    /vendor/rails/actionpack/lib/action_controller/layout.rb:241:in
`__send__'
    /vendor/rails/actionpack/lib/action_controller/layout.rb:241:in
`candidate_for_layout?'
    /vendor/rails/actionpack/lib/action_controller/layout.rb:255:in
`pick_layout'
    /vendor/rails/actionpack/lib/action_controller/base.rb:864:in
`render_without_benchmark'
    /vendor/rails/actionpack/lib/action_controller/benchmarking.rb:
51:in `render'
    /vendor/rails/activesupport/lib/active_support/core_ext/
benchmark.rb:8:in `realtime'
    /vendor/rails/actionpack/lib/action_controller/benchmarking.rb:
51:in `render'
    /vendor/rails/actionpack/lib/action_controller/mime_responds.rb:
135:in `send'
    /vendor/rails/actionpack/lib/action_controller/mime_responds.rb:
135:in `custom'
    /vendor/rails/actionpack/lib/action_controller/mime_responds.rb:
164:in `call'
    /vendor/rails/actionpack/lib/action_controller/mime_responds.rb:
164:in `respond'
    /vendor/rails/actionpack/lib/action_controller/mime_responds.rb:
158:in `each'
    /vendor/rails/actionpack/lib/action_controller/mime_responds.rb:
158:in `respond'
    /vendor/rails/actionpack/lib/action_controller/mime_responds.rb:
107:in `respond_to'
    /app/controllers/attachments_controller.rb:22:in `show'
    /vendor/rails/actionpack/lib/action_controller/base.rb:1175:in
`send'
    /vendor/rails/actionpack/lib/action_controller/base.rb:1175:in
`perform_action_without_filters'
    /vendor/rails/actionpack/lib/action_controller/filters.rb:617:in
`call_filters'
    /vendor/rails/actionpack/lib/action_controller/filters.rb:610:in
`perform_action_without_benchmark'

Kind regards, Erik

I've also experienced this problem, I need to use new functionality in
edge rails and this has broken my FlexImage setup. I did try just
creating an empty 'compile' method but unfortunately this created more
problems.

Anyone had any joy yet?

RobL

Erik Dahlstrand wrote:

This is now resolved it seems :slight_smile:

http://github.com/Squeegy/fleximage/commit/1ed1b457d7c946926b695655395a603b1a1e64a7

RobL

pgdstryr@googlemail.com wrote: