Heroku vs. local WEBrick: How could be this error be undetected?

I had the interesting case, where my application worked find locally
(using WEBrick), but the version deployed to Heroku crashed. It was a
syntax error, in a very short controller file, and I could easily
verify, that my version and the one at Heroku was identical.

What struck me, was the kind of error: In my class, I used by mistake

  private:

instead of

  private

(note the colon at the end) - perhaps I was thinking too much C++
recently - but I don't understand why I didn't get this error locally as
well!

I therefore restarte the local server and verified that it worked, and
then pushed the files to heroku, to make sure that they are REALLY the
same everywhere, and still, only at Heroku I got the error message.

I then fixed it locally, pushed it again, and now it works everywhere.

This is creepy: How can it be, that such a serious error gets unnoticed
on my local system?

Ronald

Are you running *exactly* the same version of Ruby?

Colin

It's 2.1.1p76 in both cases.