Help installing redmine

I am trying to install redmine on my Centos 5.8 box per
http://www.redmine.org/projects/redmine/wiki/HowTo_install_Redmine_on_CentOS_5.
Redmine is based on the Ruby on Rails framework. I've requested help on
that site but haven't been able to get any help. I feel like a baby,
but please please please help.

I went with:

ruby-1.8.7.p358.tar.gz (per the article)
rubygems-1.4.2.tgz (per the article)
redmine-2.0.3.tar.gz (instead of redmine-1.3.2.tar.gz as done with the
tutorial)

Then when I got to the bundle install part...

[root@vps redmine]# bundle install
You cannot specify the same gem twice with different version
requirements. You specified: i18n (~> 0.6.0) and i18n (= 0.4.2)

So I comment out gem "i18n", "0.4.2" in /home/site1/redmine/Gemfile

[root@vps redmine]# bundle install
You cannot specify the same gem twice with different version
requirements. You specified: coderay (~> 1.0.6) and coderay (~> 0.9.7)

So I comment out gem "coderay", "~>0.9.7" in /home/site1/redmine/Gemfile

[root@vps redmine]# bundle install
Fetching gem metadata from http://rubygems.org/
Fetching gem metadata from http://rubygems.org/
Bundler could not find compatible versions for gem "rack":
  In Gemfile:
    rails (= 3.2.6) ruby depends on
      rack (~> 1.4.0) ruby

    rack (1.1.0)

Could anyone help? Please please please again (dang, I am a baby). Thank
you

Please paste in the Gemfile and Gemfile.lock.

Weston, Below is the Gemfile. Which Gemfile.lock should I post? Thank
you

[root@localhost html]# find / -name Gemfile.lock
/usr/local/lib/ruby/gems/1.8/gems/mail-2.4.4/Gemfile.lock
/usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.14/test/stub/rails_apps/3.0/empty/Gemfile.lock
/usr/local/lib/ruby/gems/1.8/gems/rack-test-0.6.1/Gemfile.lock
/usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.15/test/stub/rails_apps/3.0/empty/Gemfile.lock

***** /var/www/redmine/Gemfile ******

source 'http://rubygems.org'

gem 'rails', '3.2.6'
gem 'prototype-rails', '3.2.1'
gem "i18n", "~> 0.6.0"
gem "coderay", "~> 1.0.6"
gem "fastercsv", "~> 1.5.0", :platforms => [:mri_18, :mingw_18, :jruby]
gem "builder"

# Optional gem for LDAP authentication
group :ldap do
  gem "net-ldap", "~> 0.3.1"
end

# Optional gem for OpenID authentication
group :openid do
  gem "ruby-openid", "~> 2.1.4", :require => "openid"
  gem "rack-openid"
end

# Optional gem for exporting the gantt to a PNG file, not supported with
jruby
platforms :mri, :mingw do
  group :rmagick do
    # RMagick 2 supports ruby 1.9
    # RMagick 1 would be fine for ruby 1.8 but Bundler does not support
    # different requirements for the same gem on different platforms
    gem "rmagick", ">= 2.0.0"
  end
end

# Database gems
platforms :mri, :mingw do
  group :postgresql do
    gem "pg", ">= 0.11.0"
  end

  group :sqlite do
    gem "sqlite3"
  end
end

platforms :mri_18, :mingw_18 do
  group :mysql do
    gem "mysql"
  end
end

platforms :mri_19, :mingw_19 do
  group :mysql do
    gem "mysql2", "~> 0.3.11"
  end
end

platforms :jruby do
  gem "jruby-openssl"

  group :mysql do
    gem "activerecord-jdbcmysql-adapter"
  end

  group :postgresql do
    gem "activerecord-jdbcpostgresql-adapter"
  end

  group :sqlite do
    gem "activerecord-jdbcsqlite3-adapter"
  end
end

group :development do
  gem "rdoc", ">= 2.4.2"
  gem "yard"
end

group :test do
  gem "shoulda", "~> 2.11"
  gem "mocha"
end

local_gemfile = File.join(File.dirname(__FILE__), "Gemfile.local")
if File.exists?(local_gemfile)
  puts "Loading Gemfile.local ..." if $DEBUG # `ruby -d` or `bundle -v`
  instance_eval File.read(local_gemfile)
end

# Load plugins' Gemfiles
Dir.glob File.expand_path("../plugins/*/Gemfile", __FILE__) do |file|
  puts "Loading #{file} ..." if $DEBUG # `ruby -d` or `bundle -v`
  instance_eval File.read(file)
end

Each of those are for a specific gem (IE, mail-2.4.4, passenger-3.0.14, etc). Is there a Gemfile.lock file that complements the Gemfile you pasted in and is in the Redmine application folder?

Weston

Hi Weston,

No, the four Gemfile.lock file are the only ones on my computer.

Thanks

So you followed the article on some things, but not others? Why?

FWIW, I just tried a Redmine install on my Mac using the current Ruby
1.9.3-p125 release and other than not having ImageMagick available
bundler ran right through.

So you might want to either use the same version of Redmine that the
tutorial references, or update your Ruby installation.

HTH,

So I tried this, and got a Gemfile.lock specific to my Redmine src code instance,

git clone git://github.com/redmine/redmine.git

cd redmine

bundle install --path vendor --without=production

bundle package

This automatically generated the following Gemfile.lock. Then I can trace gems and their versions // depdendent versions.

GEM

remote: http://rubygems.org/

specs:

actionmailer (3.2.6)

  actionpack (= 3.2.6)

  mail (~> 2.4.4)

actionpack (3.2.6)

  activemodel (= 3.2.6)

  activesupport (= 3.2.6)

  builder (~> 3.0.0)

  erubis (~> 2.7.0)

  journey (~> 1.0.1)

  rack (~> 1.4.0)

  rack-cache (~> 1.2)

  rack-test (~> 0.6.1)

  sprockets (~> 2.1.3)

activemodel (3.2.6)

  activesupport (= 3.2.6)

  builder (~> 3.0.0)

activerecord (3.2.6)

  activemodel (= 3.2.6)

  activesupport (= 3.2.6)

  arel (~> 3.0.2)

  tzinfo (~> 0.3.29)

activeresource (3.2.6)

  activemodel (= 3.2.6)

  activesupport (= 3.2.6)

activesupport (3.2.6)

  i18n (~> 0.6)

  multi_json (~> 1.0)

arel (3.0.2)

builder (3.0.0)

coderay (1.0.7)

erubis (2.7.0)

fastercsv (1.5.5)

hike (1.2.1)

i18n (0.6.0)

journey (1.0.4)

jquery-rails (2.0.2)

  railties (>= 3.2.0, < 5.0)

  thor (~> 0.14)

json (1.7.4)

mail (2.4.4)

  i18n (>= 0.4.0)

  mime-types (~> 1.16)

  treetop (~> 1.4.8)

metaclass (0.0.1)

mime-types (1.19)

mocha (0.12.1)

  metaclass (~> 0.0.1)

multi_json (1.3.6)

mysql (2.8.1)

mysql2 (0.3.11)

net-ldap (0.3.1)

pg (0.14.0)

polyglot (0.3.3)

rack (1.4.1)

rack-cache (1.2)

  rack (>= 0.4)

rack-openid (1.3.1)

  rack (>= 1.1.0)

  ruby-openid (>= 2.1.8)

rack-ssl (1.3.2)

  rack

rack-test (0.6.1)

  rack (>= 1.0)

rails (3.2.6)

  actionmailer (= 3.2.6)

  actionpack (= 3.2.6)

  activerecord (= 3.2.6)

  activeresource (= 3.2.6)

  activesupport (= 3.2.6)

  bundler (~> 1.0)

  railties (= 3.2.6)

railties (3.2.6)

  actionpack (= 3.2.6)

  activesupport (= 3.2.6)

  rack-ssl (~> 1.3.2)

  rake (>= 0.8.7)

  rdoc (~> 3.4)

  thor (>= 0.14.6, < 2.0)

rake (0.9.2.2)

rdoc (3.12)

  json (~> 1.4)

rmagick (2.13.1)

ruby-openid (2.1.8)

shoulda (2.11.3)

sprockets (2.1.3)

  hike (~> 1.2)

  rack (~> 1.0)

  tilt (~> 1.1, != 1.3.0)

sqlite3 (1.3.6)

test-unit (2.5.1)

thor (0.15.4)

tilt (1.3.3)

treetop (1.4.10)

  polyglot

  polyglot (>= 0.3.1)

tzinfo (0.3.33)

yard (0.8.2.1)

PLATFORMS

ruby

DEPENDENCIES

activerecord-jdbcmysql-adapter

activerecord-jdbcpostgresql-adapter

activerecord-jdbcsqlite3-adapter

builder

coderay (~> 1.0.6)

fastercsv (~> 1.5.0)

i18n (~> 0.6.0)

jquery-rails (~> 2.0.2)

jruby-openssl

mocha (= 0.12.1)

mysql

mysql2 (~> 0.3.11)

net-ldap (~> 0.3.1)

pg (>= 0.11.0)

rack-openid

rails (= 3.2.6)

rdoc (>= 2.4.2)

rmagick (>= 2.0.0)

ruby-openid (~> 2.1.4)

shoulda (~> 2.11)

sqlite3

test-unit

yard