GLoc Internationalization Plugin error

Hi,

I just installed the GLoc plugin, and set up my application to use symbols instead of hard coded strings. I did this for the English, language, and everything worked like a charm. I then added a fr.yml (french translation file) to the /lang directory, and suddenly the application won't load any views. here is a dump of the error I am getting:

"és " ./script/../config/../vendor/plugins/gloc/lib/gloc-internal.rb:147:in `iconv' ./script/../config/../vendor/plugins/gloc/lib/gloc-internal.rb:147:in `_set_valu e_charset' ./script/../config/../vendor/plugins/gloc/lib/gloc.rb:181:in `actual_load_locali zed_strings' ./script/../config/../vendor/plugins/gloc/lib/gloc.rb:180:in `each' ./script/../config/../vendor/plugins/gloc/lib/gloc.rb:180:in `actual_load_locali zed_strings' ./script/../config/../vendor/plugins/gloc/lib/gloc.rb:179:in `open' ./script/../config/../vendor/plugins/gloc/lib/gloc.rb:179:in `actual_load_locali zed_strings' ./script/../config/../vendor/plugins/gloc/lib/gloc.rb:166:in `each' ./script/../config/../vendor/plugins/gloc/lib/gloc.rb:166:in `actual_load_locali zed_strings' ./script/../config/../vendor/plugins/gloc/lib/gloc-dev.rb:76:in `_assert_gloc_st rings_up_to_date' ./script/../config/../vendor/plugins/gloc/lib/gloc-dev.rb:74:in `each' ./script/../config/../vendor/plugins/gloc/lib/gloc-dev.rb:74:in `_assert_gloc_st rings_up_to_date' (eval):3:in `_l' ./script/../config/../vendor/plugins/gloc/lib/gloc.rb:17:in `l' ./script/../config/../app/models/operator_ap_record.rb:43 /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:203:in `load_without_new_constant_marking' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:203:in `load_file' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:342:in `new_constants_in' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:202:in `load_file' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:94:in `require_or_load' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:60:in `depend_on' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:442:in `require_dependency' /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/ deprecated_d ependencies.rb:54:in `require_dependencies' /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/ deprecated_d ependencies.rb:52:in `each' /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/ deprecated_d ependencies.rb:52:in `require_dependencies' /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/action_controller/ deprecated_d ependencies.rb:12:in `model_without_deprecation' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ deprecation.r b:94:in `model' ./script/../config/../app/controllers/application.rb:42 /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:203:in `load_without_new_constant_marking' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:203:in `load_file' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:342:in `new_constants_in' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:202:in `load_file' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:94:in `require_or_load' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:60:in `depend_on' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:442:in `require_dependency' /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/dispatcher.rb:110:in `prepare_applic ation' /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/dispatcher.rb:39:in `dispatch' /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/webrick_server.rb:113:in `handle_dis patch' /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/webrick_server.rb:79:in `service' /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service' /usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run' /usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread' /usr/lib/ruby/1.8/webrick/server.rb:162:in `start' /usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread' /usr/lib/ruby/1.8/webrick/server.rb:95:in `start' /usr/lib/ruby/1.8/webrick/server.rb:92:in `each' /usr/lib/ruby/1.8/webrick/server.rb:92:in `start' /usr/lib/ruby/1.8/webrick/server.rb:23:in `start' /usr/lib/ruby/1.8/webrick/server.rb:82:in `start' /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/webrick_server.rb:63:in `dispatch' /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/servers/ webrick.rb:59 /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_requi re' /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:495:in `require' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:342:in `new_constants_in' /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/ dependencies. rb:495:in `require' /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/server.rb:39 /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_requi re' /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require' script/server:3

I have checked that iconv is properly installed (looked on the wiki, and through irb tried "require 'iconv'", which returns true), so I don't think that is the issue. I have also tried setting the encoding for the french file using the set_charset function, where i tried setting it to both utf8 and ISO-8859-1, both of which should support the accented characters, but this also didn't work.

Has anybody else used GLoc, and have any advice? I'm can't seem to get to the route of the problem of why simply adding a new language file causes this huge crash.

Thanks,

Simon