GlassFish gem 0.9.5 released

I am pleased to announce availability of GlassFish gem 0.9.5. It was
released in quick succession of 0.9.4 as a fix in 0.9.4 version broke
GlassFish gem integration with NetBeans 6.7. RC1.
GlassFish gem documentation at: http://glassfishgem.rubyforge.org/
Bugs fixed in this release:

23754 glassfish gem rails dependencies defect

24633 Better checking for arguments

24787 Problem with config.load_paths

24828 deadlock in GFFileHandler

25068 --pid option never works

25169 Add support for logging message on console

25252 cannot start if glassfish gem file is readonly: \domains\domain1\config\logging.properties

25253 extra initialization of Rails inside grizzly-jruby.jar causes problems

25254 grizzly helper in grizzly-jruby.jar doesn’t handle numeric headers

25424 can’t find header dir for ruby

25560 Starting multiple glassfish instances seems to have logging problems

25970 Debugging via NetBeans: setting breakpoints fails with error message on server console.

5404 SQLite3 with v3 Gem requires additional database configuration

7380 Duplicate glassfish scripts in JRUBY_HOME/bin

[1]http://rubyforge.org/tracker/index.php?group_id=5450&atid=21080

[2]http://rubyforge.org/forum/forum.php?forum_id=21309

Vivek, I tried downloading this gem without success using

sudo gem install glassfish

ERROR: could not find gem glassfish locally or in a repository

Also, does the gem include the glassfish jar from

https://glassfish.dev.java.net/

or is this another download?

Thanks in advance,

-Conrad

Conrad,

I wonder if this is some network or Rubyforge mirror issue. I just tried installing it installs just fine. I am assuming you are trying to install it on JRuby installation.

Glassfish gem is based on the glassfish v3 kernel so it has everything (all the jar v3 kernel jar files), you dont need to install anything.

So this is what you would do.

-install jruby

  • jruby -S gem install glassfish

-vivek.