Getting rspec error: Net::SMTPServerBusy: Relay access denied

I’m trying to test registration emails (sent with devise), and I keep getting the error:

Net::SMTPServerBusy: 454 4.7.1 <model_spec@example.com>: Relay access denied

I’m running Rails 3.2.11 with Capybara, and I have (temporarily) chopped my spec_helper.rb and test.rb files down to the bare minimum, still getting the error above.

spec_helper.rb:

require 'rubygems'
require 'spork'

Spork.prefork do
  ENV["RAILS_ENV"] ||= 'test'
  require File.expand_path("../../config/environment", __FILE__)
  require 'rspec/rails'
  require 'rspec/autorun'
  require 'capybara/rspec'
  Dir[Rails.root.join("spec/support/**/*.rb")].each {|f| require f}

  RSpec.configure do |config|
    config.use_transactional_fixtures = true
    config.infer_base_class_for_anonymous_controllers = false
  end
end

Spork.each_run do
  FactoryGirl.reload
end

test.rb:

Upficial::Application.configure do
  config.whiny_nils = true
  config.consider_all_requests_local = true
  config.action_controller.perform_caching = false
  config.action_mailer.delivery_method = :test
end

The test itself is very straightforward:

require 'spec_helper'

describe User do
  it "sends a confirmation email" do
    @user = FactoryGirl.create(:user, email: "model_spec@example.com", username: "model_spec")
    @user.    send_confirmation_instructions
ActionMailer::Base.deliveries.last.to.should == [@user.email]
  end
end

I get the same result whether I run with guard/spork or with ‘rspec spec/models/user_spec.rb’; the test always fails with

Net::SMTPServerBusy: 454 4.7.1 <model_spec@example.com>: Relay access denied

Any idea on what configurations should be changed, if any?

I'm trying to test registration emails (sent with devise), and I keep getting the error:

Net::SMTPServerBusy: 454 4.7.1 <model_spec@example.com>: Relay access denied

I'm running Rails 3.2.11 with Capybara, and I have (temporarily) chopped my spec_helper.rb and test.rb files down to the bare minimum, still getting the error above.

spec_helper.rb:

require 'rubygems' require 'spork'

Spork.prefork do   ENV["RAILS_ENV"] ||= 'test'

The *ONLY* thing I can think of here is that RAILS_ENV is set to something other than test -- this might explain why test.rb isn't getting picked up either. But I am stumped.

  require File.expand_path("../../config/environment", __FILE__)   require 'rspec/rails'   require 'rspec/autorun'   require 'capybara/rspec'   Dir[Rails.root.join("spec/support/**/*.rb")].each {|f| require f}

  RSpec.configure do |config|     config.use_transactional_fixtures = true     config.infer_base_class_for_anonymous_controllers = false   end end

Spork.each_run do   FactoryGirl.reload end

test.rb:

Upficial::Application.configure do   config.whiny_nils = true   config.consider_all_requests_local = true   config.action_controller.perform_caching = false   config.action_mailer.delivery_method = :test

According to the guides, this is redundant, but I think I'd still leave it in.