gem installation failed

i got this error message while installing mysql gem.....

kindly help me to solve this issue....

JRuby limited openssl loaded. gem install jruby-openssl for full
support.
http://wiki.jruby.org/wiki/JRuby_Builtin_OpenSSL
Building native extensions. This could take a while...
ERROR: Error installing mysql:
  ERROR: Failed to build gem native extension.

C:/Program Files/NetBeans 6.7.1/ruby2/jruby-1.2.0/bin/jruby.bat
extconf.rb install mysql --no-rdoc --no-ri
The system cannot find the path specified.
'cmd' is not recognized as an internal or external command,
operable program or batch file.

Gem files will remain installed in C:/Program Files/NetBeans
6.7.1/ruby2/jruby-1.2.0/lib/ruby/gems/1.8/gems/mysql-2.8.1 for
inspection.
Results logged to C:/Program Files/NetBeans
6.7.1/ruby2/jruby-1.2.0/lib/ruby/gems/1.8/gems/mysql-2.8.1/ext/mysql_api/gem_make.out

thanks in advance....

I'm not a Windows user, nor a J*** user, not even a Netbeans user, but
it seems like Netbeans is trying to execute "cmd" to get a DOS
console.
Try to open it your self and install the gem via the gem command.

Hope it helps.

You probably want the `jdbc-mysql` and (if you're using Rails) the
activerecord-jdbcmysql-adapter gem(s) instead.

HTH,

Devendran Ganesan wrote:

i got this error message while installing mysql gem.....

kindly help me to solve this issue....

JRuby limited openssl loaded. gem install jruby-openssl for full
support.
http://wiki.jruby.org/wiki/JRuby_Builtin_OpenSSL
Building native extensions. This could take a while...
ERROR: Error installing mysql:
  ERROR: Failed to build gem native extension.

C:/Program Files/NetBeans 6.7.1/ruby2/jruby-1.2.0/bin/jruby.bat
extconf.rb install mysql --no-rdoc --no-ri
The system cannot find the path specified.
'cmd' is not recognized as an internal or external command,
operable program or batch file.

Deva, any luck with this issue? Having the exact same problem when I
upgraded to Netbeans 6.7.1 on Windows XP.