gem install rails issue CRC error

im trying to install rails with gem. i have compiled 1.8.6 from source
and am running gem 1.1.1

here is the output:

[root@webapp1 ~]# gem install rails --include-dependencies --verbose
--backtrace
INFO: `gem install -y` is now default and will be removed
INFO: use --ignore-dependencies to install only the gems you list
connection reset after 2 requests, retrying
Missing metadata for 14022 gems
Bulk updating Gem source index for: http://gems.rubyforge.org/
Installing gem actionpack-2.1.0
ERROR: While executing gem ... (Zlib::GzipFile::CRCError)
    invalid compressed data -- crc error
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/package/tar_input.rb:55:in
`close'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/package/tar_input.rb:55:in
`initialize'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/package/tar_reader.rb:46:in
`each'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/package/tar_reader.rb:37:in
`loop'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/package/tar_reader.rb:37:in
`each'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/package/tar_input.rb:33:in
`initialize'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/package/tar_input.rb:18:in
`new'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/package/tar_input.rb:18:in
`open'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:56:in
`open'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/format.rb:67:in
`from_io'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/format.rb:51:in
`from_file_by_path'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/format.rb:50:in
`open'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/format.rb:50:in
`from_file_by_path'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:81:in
`initialize'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:200:in
`new'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:200:in
`install'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:183:in
`each'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:183:in
`install'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:73:in
`execute'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:70:in
`each'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:70:in
`execute'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/command.rb:136:in
`invoke'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:104:in
`process_args'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:74:in
`run'
        /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:39:in
`run'
        /usr/local/bin/gem:24

i have retried multiple times but am still getting the same error. i am
running centos 5. i double checked and i do have the zlib ruby
libraries installed.