garbage #_=_ in url after authenticated w Devise/Omniauth

very strange … after being authenticated w FB/Google , the user is signe din and redirected to root_url

In console :

Started GET “/users/auth/facebook?display=page”

(facebook) Request phase initiated.

Started GET "/users/auth/facebook/callback?code=AQCHRMjDO…

(facebook) Callback phase initiated.

Processing by Users::OmniauthCallbacksController#facebook as HTML

     Parameters: {"code"=>"AQCHRMjDOp2VW56_......

User Load (0.6ms) SELECT users.* FROM users

   UPDATE `users` SET `last_sign_in_at`
  COMMIT

Redirected to http://lvh.me:3000/

Completed 302 Found in 3358ms (ActiveRecord: 3.2ms)

Started GET “/” for 127.0.0.1 at 2012-11-14 12:08:51 +0100

Processing by WelcomeController#home as HTML # no action in welcome_controller#home , only display of a statuc home page view

Everything is fine BUT the url displayed in the browser is weird : some garbage http://lvh.me:3000/#=

any clue about where I should look into ?

thnaks

found a clue , but don’t know yet how to get rid of it

The callback url from FB contains these characters at the end of the code … #/=

seems to be append to the redirect url ( root_url in my case)

http://lvh.me:3000/users/auth/facebook/callback?code=AQAPAicWohKyaTYEDqZIfDGgho9fpEeu-r7749zRPfdF7rd7L5HrHUxU6gqmjO7lBQPgkp3UE-5qKJg9zYlGUxA-0rgJphBlpYwXyao6kGYzyztFvSZJ_muF__Py_QjSufIzLYcZsaEzSZ2TN5D9whczeXBC_8zbjEZNhHnJki4QgV9B862-lihYnWe5UWvKfNTdPGC0E_EzBAfegOXSdoKl#=

[SOLVED] it’s a FB addition …

[SOLVED] from FB … Change in Session Redirect Behavior
This week, we started adding a fragment #= to the redirect_uri when this field is left blank. Please ensure that your app can handle this behavior.

added to my application.js

if (window.location.href.indexOf(’#=’) > 0) {

window.location = window.location.href.replace(/#.*/, ‘’);

}