ffmpeg audio not working

I'm converting videos to .flv but I can't hear any sound. Is this
ffmpeg command correct?

ffmpeg -i #{path} -an -s 480x360 -vcodec flv -r 25 -qscale 8 -f flv -y
#{flv}

Thank you.

The -an option is for disabling sound. You’ll want to specify -acodec instead, eg:

ffmpeg -i #{path} -acodec mp3 -s 480x360 -vcodec flv -r 25 -qscale 8 -f flv -y #{flv}