Expected ... to define ... errors after restart

Hey there,

I rebooted my server after a power outage and cannot get my site to
work again. I am getting a lot of errors like:

Expected /home/jonas/rails/td/current/config/../app/models/post.rb to
define Post

and similar. The weird thing is that I changed nothing about the app.
It just refuses to work. I redployed the app (capistrano, restarted
the mongrel cluster, rebooted the server, nothing helps. Initially I
suspected acts_as_ferret, I have seen similar errors caused by aaf
before. I tried restarting the DRb process, then I tried removing all
calls to acts_as_ferret, still, same errors.

This is a major pain, since my application has been offline for a day,
and I have no idea what even to try. Any help would be greatly
appreciated!

/Jonas

JN_Coward wrote:

Hey there,

I rebooted my server after a power outage and cannot get my site to
work again. I am getting a lot of errors like:

Expected /home/jonas/rails/td/current/config/../app/models/post.rb to
define Post

and similar. The weird thing is that I changed nothing about the app.
It just refuses to work. I redployed the app (capistrano, restarted
the mongrel cluster, rebooted the server, nothing helps. Initially I
suspected acts_as_ferret, I have seen similar errors caused by aaf
before. I tried restarting the DRb process, then I tried removing all
calls to acts_as_ferret, still, same errors.

This is a major pain, since my application has been offline for a day,
and I have no idea what even to try. Any help would be greatly
appreciated!

It does look a Ferret/DRb related problem as seen here:

http://www.ruby-forum.com/topic/77708

Restarting for the affected people in the above topic worked, so I'm not sure why it isn't for you.