Error with Gem Outdated command

Trying to run 'gem outdated' on OS X (10.6.3) and I'm getting:

sudo gem outdated
ERROR: While executing gem ... (NoMethodError)
    undefined method `first' for nil:NilClass

Here's my info:

john$ gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.7
  - RUBY VERSION: 1.8.7 (2009-06-08 patchlevel 173)
[universal-darwin10.0]
  - INSTALLATION DIRECTORY: /Library/Ruby/Gems/1.8
  - RUBY EXECUTABLE:
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
  - EXECUTABLE DIRECTORY: /usr/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - universal-darwin-10
  - GEM PATHS:
     - /Library/Ruby/Gems/1.8
     - /Users/john/.gem/ruby/1.8

John T. wrote:

Trying to run 'gem outdated' on OS X (10.6.3) and I'm getting:

More info:

gem outdated -V
GET http://rubygems.org/latest_specs.4.8.gz
302 Found
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
200 OK
ERROR: While executing gem ... (NoMethodError)
    undefined method `first' for nil:NilClass

john$ gem outdated --backtrace
ERROR: While executing gem ... (NoMethodError)
    undefined method `first' for nil:NilClass
  /Library/Ruby/Site/1.8/rubygems/commands/outdated_command.rb:26:in
`execute'
  /Library/Ruby/Site/1.8/rubygems/commands/outdated_command.rb:21:in
`each'
  /Library/Ruby/Site/1.8/rubygems/commands/outdated_command.rb:21:in
`execute'
  /Library/Ruby/Site/1.8/rubygems/command.rb:270:in `invoke'
  /Library/Ruby/Site/1.8/rubygems/command_manager.rb:134:in
`process_args'
  /Library/Ruby/Site/1.8/rubygems/command_manager.rb:104:in `run'
  /Library/Ruby/Site/1.8/rubygems/gem_runner.rb:58:in `run'
  /usr/bin/gem:21

Not one to bump topics, but I'm still getting this error.. and it's been
2 months...

Thanks

John T. wrote:
Trying to run 'gem outdated' on OS X (10.6.3) and I'm getting:

sudo gem outdated
ERROR: While executing gem ... (NoMethodError)
     undefined method `first' for nil:NilClass

Here's my info:

john$ gem env
RubyGems Environment:
   - RUBYGEMS VERSION: 1.3.7
   - RUBY VERSION: 1.8.7 (2009-06-08 patchlevel 173)
[universal-darwin10.0]
   - INSTALLATION DIRECTORY: /Library/Ruby/Gems/1.8
   - RUBY EXECUTABLE:
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
   - EXECUTABLE DIRECTORY: /usr/bin
   - RUBYGEMS PLATFORMS:
     - ruby
     - universal-darwin-10
   - GEM PATHS:
      - /Library/Ruby/Gems/1.8
      - /Users/john/.gem/ruby/1.8

John T. wrote:

Not one to bump topics, but I'm still getting this error.. and it's been
2 months...

I can't help, but you'll get more luck on the Rubygems mailing list or
the main Ruby list.