error while installing ruby with rvm on snowleopard

I am getting some weird error while installing ruby with rvm on
snowleopard.
Can anyone help me out with this.

Retrieving rubygems-1.8.6
curl: (6) Couldn't resolve host 'production.cf.rubygems.org'
ERROR: There was an error, please check
/Users/prem/.rvm/log/ruby-1.8.7-p352/*.log. Next we'll try to fetch via
http.
Trying http:// URL instead.
curl: (6) Couldn't resolve host 'production.cf.rubygems.org'
ERROR: There was an error, please check
/Users/prem/.rvm/log/ruby-1.8.7-p352/*.log
ERROR: There has been an error while trying to fetch the source.
Halting the installation.
ruby-1.8.7-p352 - adjusting #shebangs for (gem irb erb ri rdoc testrb
rake).
ruby-1.8.7-p352 - #importing default gemsets (/Users/prem/.rvm/gemsets/)

thanks,
Aashish

Don't ever post errors without the command that generated the errors.

Sounds like DNS issue or the host is down.

Can you ping production.cf.rubygems.org?

-D

7stud -- wrote in post #1013293:

Don't ever post errors without the command that generated the errors.

The below is the command i typed. Can you help......

Thu Jul 28 11:37:32 xxxx $ rvm install 1.8.7
Installing Ruby from source to: /Users/prem/.rvm/rubies/ruby-1.8.7-p352,
this may take a while depending on your cpu(s)...

ruby-1.8.7-p352 - #fetching
ruby-1.8.7-p352 - #extracting ruby-1.8.7-p352 to
/Users/prem/.rvm/src/ruby-1.8.7-p352
ruby-1.8.7-p352 - #extracted to /Users/prem/.rvm/src/ruby-1.8.7-p352
ruby-1.8.7-p352 - #configuring
ruby-1.8.7-p352 - #compiling
ruby-1.8.7-p352 - #installing
Retrieving rubygems-1.8.6
curl: (6) Couldn't resolve host 'production.cf.rubygems.org'
ERROR: There was an error, please check
/Users/prem/.rvm/log/ruby-1.8.7-p352/*.log. Next we'll try to fetch via
http.
Trying http:// URL instead.
curl: (6) Couldn't resolve host 'production.cf.rubygems.org'
ERROR: There was an error, please check
/Users/prem/.rvm/log/ruby-1.8.7-p352/*.log
ERROR: There has been an error while trying to fetch the source.
Halting the installation.
ruby-1.8.7-p352 - adjusting #shebangs for (gem irb erb ri rdoc testrb
rake).
ruby-1.8.7-p352 - #importing default gemsets (/Users/prem/.rvm/gemsets/)
Install of ruby-1.8.7-p352 - #complete
Thu Jul 28 11:37:32 xxxx $
Thu Jul 28 11:37:32 xxxx $ curl: (6) Couldn't resolve host
'production.cf.rubygems.org'
-bash: syntax error near unexpected token `6'
Thu Jul 28 11:49:40 xxxx $

Dan Sadaka wrote in post #1013346:

Sounds like DNS issue or the host is down.

Can you ping production.cf.rubygems.org?

-D

I did 'dig production.cf.rubygems.org' got error as could not find host.
I again did 'dig http://production.cf.rubygems.org' got a success.

But I dont get how to solve installing ruby with rvm. Can you help me