error when using facebooker

hi all,

i am rails newbie. so, please be merciful if you found this question
stupid :smiley:

i want to ADD facebook capability to my project. fyi, my project is
using prototype and openlayer. the amount of work done (by others)
using prototype and openlayer is quite large, so that i can't afford
to make conflict with those libraries.

for the facebook capability, i use facebooker. when i create the
prototype (i mean, the small version, not prototype javascript
library) in a separate (blank) project, facebooker worked fine. but
when i integrated it to my true project, somehow the page is not
correctly rendered.

in firebug console, i found some javascript errors. i found that all
those errors are basically related to prototype. it happens even
though i have imported the facebooker javascript library to my page.
for example, this one: "Element.observe is not a function"

anybody here would like to enlighten me? especially about facebooker -
prototype relationship.

thank you

fajrian wrote:

hi all,

i am rails newbie. so, please be merciful if you found this question
stupid :smiley:

i want to ADD facebook capability to my project. fyi, my project is
using prototype and openlayer. the amount of work done (by others)
using prototype and openlayer is quite large, so that i can't afford
to make conflict with those libraries.

for the facebook capability, i use facebooker. when i create the
prototype (i mean, the small version, not prototype javascript
library) in a separate (blank) project, facebooker worked fine. but
when i integrated it to my true project, somehow the page is not
correctly rendered.

in firebug console, i found some javascript errors. i found that all
those errors are basically related to prototype. it happens even
though i have imported the facebooker javascript library to my page.
for example, this one: "Element.observe is not a function"

anybody here would like to enlighten me? especially about facebooker -
prototype relationship.

Because of Facebook's JavaScript munging, you can't use Prototype.js in
a Facebook canvas app IIRC (although you can in an iframe app). That's
why Facebooker provides facebooker.js in the first place.

Note that this is mostly not a Rails question, and would probably be
better directed to the Facebook dev forum.

thank you

Best,