Error installing gems 0.9.4.. can anybody help?

I wonder if this is similar to the Standard Gems Problem updating to 0.9.x
where your sources cache is not migrated to the new format? There's a file
called /usr/[local/]lib/ruby/gems/1.8/source_cache; delete it and see if
that helps.

I'm gonna bet you've got conflicts between your Tiger ruby installation in
/usr/lib/ruby/* and your Locomotive installation. Check your path, things
like that..