elasticsearch on linux mint 18 development env

The docs at https://github.com/elastic/elasticsearch-rails just say to run gem install elasticsearch-model elasticsearch- rails
and don’t even say to put gem elasticsearch-model and gem elasticsearch-rails in my gemfile but if i don’t the webrick server won’t start I think the docs fail to mention that this is assuming elasticsearch is installed as a system service on yours or your host’s server I have installed and removed different versions of elasticsearch as a system service on my LM18Sarah desktop but haven’t been able to connect on localhost:9200 To further confuse me in package manager there’s not only elasticsearch but there’s also ruby-elasticsearch and ruby-elasticsearch-api and ruby-elasticsearch-transport What a mess What’s the right way to install elasticsearch on my system

If you've followed the official Elasticsearch installation process (which is
pretty minimal) and it's not running, *look in the logs and figure out why*.

Alternatively, for learning purposes at least, starting up an ES instance
on Amazon AWS is about as simple as possible.

hi thanks, i got it running but even still i can’t connect on 9200 and netstat shows nothing at 9200; i’ve tried plugging different values for network.host tried everything from localhost to localhost to _localhost_IPv4 but still can’t connect on 9200; although i see nothing in netstat that shows port 9200 in use i don’t know the meanings of the things listed in the output of netstat

I'm not sure what you're referring to for "different values" but on my
system I can quickly confirm elasticsearch is running by using this:

   curl http://localhost:9200

Do you get a response to that? If not, ES isn't really running :slight_smile:

Hi again Thanks It seems using apt-get install elasticsearch on linux mint 18 gets you a non-working installation so elasticsearch github page says to download the source, unzip and run bin/elasticsearch but then the system complains the package has to be installed into init.d first So I figured I’d just install the deb Surprise, there is no .deb file in the distributions/deb directory Referring to the README.textfile also says to run bin/elasticsearch So then how shall I install?