Disqus Gem; creating new threads

Hey everyone,

I need a bit of help with the Disqus gem. I can't seem to create new threads. Just to test it out, I tried to create a thread in the console:

Disqus::Api.thread_by_identifier(:forum_api_key => "the api key of the forum i want to post this comment in", :identifier => "some nutty one", :title => "test title")

TypeError: can't convert Net::HTTPMovedPermanently into String   from /home/ramon/.gem/ruby/1.8/gems/json-1.1.3/lib/json/common.rb:122:in `initialize'   from /home/ramon/.gem/ruby/1.8/gems/json-1.1.3/lib/json/common.rb:122:in `new'   from /home/ramon/.gem/ruby/1.8/gems/json-1.1.3/lib/json/common.rb:122:in `parse'   from /usr/lib/ruby/gems/1.8/gems/norman-disqus-1.0.1/lib/disqus/api.rb:188:in `thread_by_identifier'   from (irb):1

I did some reading to see what the problem might be here, and it is possible that it's because the browser sends a bunch of other stuff that the server needs. So I tried to curl it instead:

curl -d "forum_api_key=myforumsapi&identifier=blogpost3020&=title=testtitle" http://disqus.com/api/thread_by_identifier

When I press enter, nothing happens. I checked my forum, and don't see any new threads.

What should I do?

Thanks, Ramon Tayag

Okay I did more playing around, got the curl to work by wrapping the URL with quotes :s

Now I know the API works (yes, I got to that point), I still need to figure out why I can't do it in the console... unless I really am not supposed to be able to do it on the console.

Ramon Tayag

Spent more time testing it out.. and I manually typed out the code that thread_by_identifier is composed of. Apparently, the gem was missing a "/" at the end of the api URL -- it should be "http://disqus.com/thread_by_identifier/"\. I will send a bug report :slight_smile:

I tried to fork and fix it myself but I realized I have no clue. I asked around as well on rubyonrails but got no answer :stuck_out_tongue: I guess it's building only simple gems for me now.

Ramon Tayag