DEPRECATION WARNING -- fine, but I'm not doing that.

When I run my functional tests, I get (pasted from cygwin):

Started .E...DEPRECATION WARNING: @flash is deprecated! Call flash. instead of @flash.[ ]. Args: [:note] See http://www.rubyonrails.org/deprecation for details. (called from _run_rhtml_47app47views47admin47_flash46rhtml at /home/hgs/aeg_intranet/cse store/config/../app/views/admin/_flash.rhtml:2) DEPRECATION WARNING: @flash is deprecated! Call flash.keys instead of @flash.keys . Args: See http://www.rubyonrails.org/deprecation for details. (called from _run_rhtml_47app47views47admin47_flash46rhtml at /home/hgs/aeg_intranet/csestore/ config/../app/views/admin/_flash.rhtml:5) DEPRECATION WARNING: @flash is deprecated! Call flash.each_pair instead of @flash .each_pair. Args: See http://www.rubyonrails.org/deprecation for details. (ca lled from _run_rhtml_47app47views47admin47_flash46rhtml at /home/hgs/aeg_intranet /csestore/config/../app/views/admin/_flash.rhtml:7)

And when I look at the file I have: ------8<----------------------------------------     <!-- start partial flash block -->     <% if flash[:note] && ! flash[:note].empty? -%>       <div id="notice"><p>Flash note:</p><%= h(flash[:note]) %></div>     <% end -%>     <% if ! flash.keys.empty? -%>     <p>Flash:</p>       <div class="notice"><% flash.each_pair{|k,v| %><p><%= k.to_s + ": " + v.to_s -%></p>       <%} %></div>     <% end %>     <!-- end partial flash block --> ------8<----------------------------------------

What @ signs? I've just taken them out. What's the correct way to get rid of these warnings? I'm using the flash stuff for debugging at the moment, but nonetheless I'd like to do this right.

This is under Rails 1.2.3 on cygwin (with MySQL).

        Thank you,         Hugh

See http://dev.rubyonrails.org/ticket/7553 . The simplest fix is just to rename your _flash partial to something else.

Mike Gunderloy http://afreshcup.com

See http://dev.rubyonrails.org/ticket/7553 . The simplest fix is just to rename your _flash partial to something else.

The mail server has been off for a while, so hence late response.

This is not the problem. I still have _flash.rhtml, but don't get this now. I think it expanded this in other partials that were expanded, because having fixed those the warning has gone.

        Thank you         Hugh

Thanks.

        Hugh