Having a boolean .weekend? on the Date class would be a good feature. It will basically do this:

saturday? || sunday?

Makes the code cleaner and easier to read.

This introduces a localization issue – not everyone has a Saturday/Sunday weekend! Particularly Islamic countries: but also Israel, Nepal, India, and others.

Seeing as "beginning_of_week" allows for configuration of the week start
day, it doesn't seem like a huge leap to have configuration for the start
and end days of a weekend, with default values identifying Saturday and

But frankly I'd think this was more of a personal mix-in than a core