cPanel Ruby Gems

Hi,

I am trying to install will_paginate along with other plugins/gems.

However it seems I have version 1.1.1 of Ruby Gems.

I try updating it by 'gem install rubygems-update' but I get an error,

[***@cluster1 ***]$ gem install rubygems-update
Bulk updating Gem source index for: http://gems.rubyforge.org/
/usr/lib/ruby/1.8/yaml.rb:133: [BUG] Segmentation fault
ruby 1.8.6 (2007-03-13) [i686-linux]

Aborted (core dumped)

Is this to do with my host?

I am unable to add gems, plugins without the upgrade.

Thanks, Rob

Also try: gem update --system

--Jeremy

Did you find a solution to this? I am experiencing the same problem.

Michael Mike wrote:

Did you find a solution to this? I am experiencing the same problem.

I contacted my host and got them to update my Ruby Gems.

However I now get this message;

:0:Warning: Gem::SourceIndex#search support for Regexp patterns is
deprecated

Cheers, Rob

That's odd... what command produces that warning? Something is calling
Gem.source_index.search(/some_regexp/, ...) when it shouldn't.

--Matt Jones

Very odd - what version of rails is this under?

--Matt Jones

This looks like a host problem of some sort - the segmentation faults
are
a problem that older versions of Rubygems had, where they would try to
load the entire RubyForge gem listing into memory (and then fail). The
1.3.1
Rubygems now only tries to load 1000 items, so either cPanel's hitting
an
old version, or your host's memory limits are tiny. I'd recommend
opening
a ticket with your hosting provider to sort this out.

--Matt Jones