connecting to mysql on locomotive

Hi, I am having trouble connecting to mysql on a locomotive
installation. Everything is working fine through my rails application
(it is able to read the database via the database.yml configuration),
but when I try to connect through mysql Administrator or some other
GUI type tool, it says the following error.

Connection error. Could not connect to MySQL instance on localhost.
Error: Can't connect to local MySQL server through socket '/tmp/
mysql.sock' (2) (code 2002).

I tried to find the .sock file but I am not sure where to find it in
the locomotive installation so that I can map to it.

Thanks,
Tim

I have no idea what 'locomotive' is but if the database.yml file has the
correct connection information, why don't you look at what it says??
At least in all my MySQL-based Rails apps, that includes the socket
path...

HTH,

Locomotive is (was) a one-click installer for Osx that includes Ruby +
MySQL + Rails + other fancy stuff. It is no longer maintained, and
therefore should not be used anymore.

Have you tried connecting to your server by address and port instead
of using the mysql.sock file? I am not sure if Locomotive was
configured to allow connection via the socket.