Conflict in Rails and Deprecated Gem

Hi,

I am using Rails 3 RC and DBI Gem, that require deprecated gem...

But when Activerecord use a 'deprecate' method, AR use the 'deprecate'
method of 'deprecated' gem...resulting in a app error

You did not specify how you would like Rails to report deprecation
notices for your development environment, please set
config.active_support.deprecation to :log at config/environments/
development.rb
/Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
deprecated-2.0.1/lib/deprecated.rb:176:in `instance_method':
{:subclasses=>:descendants} is not a symbol (TypeError)
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
deprecated-2.0.1/lib/deprecated.rb:176:in `deprecate'
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
activerecord-3.0.0.rc/lib/active_record/base.rb:291
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
activerecord-3.0.0.rc/lib/active_record/railtie.rb:28
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:in
`call'
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:in
`to_proc'
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
railties-3.0.0.rc/lib/rails/railtie.rb:180:in `each'
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
railties-3.0.0.rc/lib/rails/railtie.rb:180:in `load_console'
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
railties-3.0.0.rc/lib/rails/application.rb:154:in `load_console'
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
railties-3.0.0.rc/lib/rails/application/railties.rb:11:in `each'
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
railties-3.0.0.rc/lib/rails/application/railties.rb:11:in `all'
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
railties-3.0.0.rc/lib/rails/application.rb:154:in `load_console'
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
railties-3.0.0.rc/lib/rails/commands/console.rb:26:in `start'
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
railties-3.0.0.rc/lib/rails/commands/console.rb:8:in `start'
  from /Users/raphael/.rvm/gems/ree-1.8.7-2010.02@rails3/gems/
railties-3.0.0.rc/lib/rails/commands.rb:23
  from script/rails:6:in `require'
  from script/rails:6

I've run into the exact same issue on Rails 3 RC.

Use this gems that i created in your Gemfile

gem ‘rails-dbi’, :require => ‘dbi’

gem ‘rails-dbd-mysql’

I created a Fork of dbi gems without deprecated gem dependecy.

**Raphael William Costa **

Telefone. +55 41 8401273
Email. raphael@raphaelcosta.net
Internet. http://www.raphaelcosta.net

Use this gems that i created in your Gemfile

gem ‘rails-dbi’, :require => ‘dbi’

gem ‘rails-dbd-mysql’

I created a Fork of dbi gems without deprecated gem dependecy.

**Raphael William Costa **

Telefone. +55 41 8401273
Email. raphael@raphaelcosta.net
Internet. http://www.raphaelcosta.net