Capistrano deploy:web:disable doesn't work

Hi all,

I'm trying to figure out why cap deploy:web:disable isn't working for my
server. I'm adding a pastie with the example apache RewriteCond I'm
using with my rails app.

http://pastie.org/587619

The document root is correct, I've just changed the username and the
name of the site domain. Pretend that the username and the site domain
are valid when looking at the pastie.

Is there something I'm doing wrong here?

The DocumentRoot is on line #5.

The Rewritecond are on lines 38,39,40, 41.

Any help would be appreciated.

Thanks.

Just as some added info:

in apache2.conf I have the following for passenger and rails:

LoadModule passenger_module
/usr/lib/ruby/gems/1.8/gems/passenger-2.2.4/ext/apache2/mod_passenger.so
PassengerRoot /usr/lib/ruby/gems/1.8/gems/passenger-2.2.4
PassengerRuby /usr/bin/ruby1.8
RailsAllowModRewrite on

The updated virtual file I am using is located here:

http://pastie.org/587697

When I issue cap deploy:web:disable

I can confirm that a maintenance.html file is written to:

/path/to/production/mydomain.com/current/public/system/maintenance.html

But, no redirects to that page occur when my site is clicked...

Alpha Blue wrote:

Hi all,

I'm trying to figure out why cap deploy:web:disable isn't working for my
server.

[...]

I've never gotten that to work either. I'm not sure why.

Best,

Seems like you might need a
RewriteEngine on
directive before that first RewriteCond