Can't get win32console gem working properly

Hi all. I must use Windows for a days and I am trying to use win32console gem. I've installed it successful and can see it at C:\ruby\lib\ruby\gems\1.8\gems, but can't use it with require():

irb

irb(main):001:0> require 'rubygems'
=> false
irb(main):002:0> require 'Win32/Console/ANSI'
LoadError: no such file to load -- Win32/Console/ANSI
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from (irb):2
irb(main):003:0> require 'Win32/Console'
LoadError: no such file to load -- Win32/Console
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from (irb):3
irb(main):004:0> require 'Win32'
LoadError: no such file to load -- Win32
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from (irb):4
irb(main):005:0>

    What am I doing wrong?

gem list

*** LOCAL GEMS ***

actionmailer (1.3.6, 1.3.5)
actionpack (1.13.6, 1.13.5)
actionwebservice (1.2.6, 1.2.5)
activerecord (1.15.6, 1.15.5)
activesupport (1.4.4)
fxri (0.3.6)
fxruby (1.6.13, 1.6.6)
hoe (1.3.0)
hpricot (0.6, 0.4)
log4r (1.0.5)
mysql (2.7.3)
rails (1.2.6, 1.2.5)
rake (0.7.3, 0.7.2)
redgreen (1.2.2)
ruby-snarl (0.0.8)
rubyforge (0.4.4)
rubygems-update (0.9.5)
sources (0.0.1)
test_notifier (0.0.5)
win32-clipboard (0.4.3, 0.4.1)
win32-dir (0.3.2, 0.3.1)
win32-eventlog (0.4.6, 0.4.3)
win32-file (0.5.5, 0.5.3)
win32-file-stat (1.2.7, 1.2.3)
win32-process (0.5.1)
win32-sapi (0.1.3)
win32-sound (0.4.0)
win32console (1.0.8)
windows-pr (0.6.2)
ZenTest (3.6.1)

    Thank you very much

    Davi Vidal

I'm having the same problem. Anybody had any luck solving it?

Tim

> Hi all. I must use Windows for a days and I am trying to use
> win32console gem. I've installed it successful and can see it at
>
> C:\ruby\lib\ruby\gems\1.8\gems, but can't use it with require():

[...]

I'm having the same problem. Anybody had any luck solving it?

  I've got nothing yet.

  Best regards,

Hi everybody,

I figured out, what the problem was:

Just renamed the path in the gems dir:

win32console-1.0.8-x86-mswin32
to
win32console-1.0.8-i386-mswin32

then it works for me.

greetinx

Rafael

This worked for me, too. Thanks, Rafael.

Not sure, but it may be a problem with rubygems v0.9.5.

Tim

If for some reason you have the folder "win32console-1.0.8-x86-
mswin32", renaming it to "win32console-1.0.8-i386-mswin32" may fix it.

- Mark