Cannot run rake on rails 3 beta 4

I am running into a brick wall when trying out Rails 3 beta 4. I am
getting this:

rails new blog
cd blog
rake --trace

rake aborted!
wrong argument type Symbol (expected Proc)
/Users/me/.rvm/gems/ruby-1.8.7-p174/gems/railties-3.0.0.beta4/lib/
rails/engine.rb:122:in `delegate'

I am running latest 10.5.x, fresh install of Ruby 1.8.7 (via rvm), and
rails 3 beta 4.

What's going on?