cannot generate a model???

So I have installed Instant Rails on my computer, and I've been following some RoR tutorials from I created a new app called music_library, and then when trying to create a model, I get something weird,

typing in: rails script/generate model Album

I receive:

exists create app/controllers File exists - script/generate

(by the way this is in dos command prompt)

NOW, I've generated a model before, and I THINK i ran rails script or rails script/generate in my rails_apps directory. Then I noticed that i had to be in my actual application directory (music_library) in this case, and when i tried to generate a model I get only these three lines, as opposed to a lot more before. Same thing happens when I try to generate a controller. And my application does not do what it's supposed to do in the tutorial (basically throws me an error)

any help?


Hi yer,

You need to replace rails script/generate.... with ruby script/ generate....

cheers, Dave

Hey Dave,

That doesn't work. Keep in mind that i am running this on a windows machine in dos prompt. Ruby seems like a command that doesn't exist

Typing: ruby script/generate model Albums returns this: ruby: No such file or directory -- script/generate (LoadError)

It will work, you just need to supply the full path to ruby i.e.

C:/path/to/ruby script/generate model Albums

krystianf wrote:

Actually, not for Instant rails. On the instant rails window, click the black "I". Bring up Rails Applications>Manage Rails Applications... In this window, click on "Create New Rails App". This brings up a command prompt in the Instant Rails environment. In particular, the ruby which comes with Instant Rails is in the path. "ruby script/generate model Albums" should now work just fine. If you are already set up in subversion, - c will add the new files.