Build sybase adapter on winxp with eclipse/cdt

Hi folks,

I try to get the sybase adapter installed. I downloaded the
sybase-ctlib from here: http://raa.ruby-lang.org/project/sybase-ctlib
and now want to build the stuff on my winxp machine somehow. I decided
to eclipse/cdt and downloaded mingw32-make, gdp and gcc.

I created a new project and imported the sybase-ctlib sources. With the
extconf.rb I created the makefile and after cleaning up some of the
windows-specific paths I run "mingw32-make all".

When running mingw32-make I get this error:
mingw32-make all
makefile:123: *** target pattern contains no `%'. Stop.

The affected lines:
117 site-install: site-install-so site-install-rb
118 site-install-so: install-so
119 site-install-rb: install-rb
120
121 .SUFFIXES: .c .m .cc .cxx .cpp .obj
122
123 {$(srcdir)}.cc{}.obj:
124 $(CXX) $(INCFLAGS) $(CXXFLAGS) $(CPPFLAGS) -c -Tp$(<:\=/)
[...] lots more off this stuff

I try to help myself reading the make manual, but I want to get the
sybase adapter running and not to become c/make expert :frowning:

Has anybody experienced this problem? Is there a good tutorial
available on how to set up this lib on windows using eclipse/cdt (I
found one using visual studio, which I donĀ“t have)?

Thanks for any hint!

Regard,

Christian

Jeremy Burks schrieb:

sorry i can't help with your error but i can offer the binaries.

What version of SybaseAse are you using? I have 12.5 and 15.

That would be great! Do you have both? I need then for ASE 12.5. But I
would be glad if you could provide the files for ASE 15.0 as well. Can
you provide a download link or do you want to send them per mail?

Thanks in advance!

Regards,

Christian

Hello,

I have only one ruby installation, I install the sybase adapter and try
the isql.rb and other stuff directly from irb and it works.

However, if I tried under RadRails I can neither open the database or
if I try using the RadRails console the require "sybsql" answers
"false".

Does anybody has an idea ?