any idea of WFKV_ constant

Hi there,

While staring rails am receiving a weird warning, does anybody know what it mean?

/home/agny/.rvm/gems/ruby-1.9.2-p290/gems/rack-1.3.4/lib/rack/backports/uri/common_192.rb:53: warning: already initialized constant WFKV_

googling for
warning: already initialized constant WFKV_
led to
http://jomcode.com/fadhil/programming-and-development/rails-warning-already-initialized-constant-wfkv_/
which may be helpful. Google found other links also so it would be
worth looking at more than one to see if there is a concensus.

Colin

Hi,

I dont remember where but I found that it’s a problem with rack-1.3.4.

You have to use 1.3.3. I haven’t done that and it is not giving me problems with the things I’m doing with rails, but its annoying to see that message everytime you do something

Hope someone can give more explanation =)

This looks to have been fixed in the rack source, just hasn’t been released yet.

https://github.com/rack/rack/issues/246

-GR