activerecord - "remove_method" fails on method "transaction"

I had a running RoR application which failed upon reboot a few days
ago. I''m on FreeBSD 4.7, ruby 1.8.5, rails 1.1.6. As far as I know,
nothing's changed, so I'm quite puzzled. Now when I run script/server
or script/console or even script/about, I get the following:

[...@... ~/...]$ ruby script/server --environment=production
/usr/local/lib/ruby/gems/1.8/gems/activerecord-1.14.4/lib/
active_record/transactions.rb:2:in `remove_method': method
`transaction' not defined in Transaction::Simple (NameError)
        from /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.14.4/lib/
active_record/transactions.rb:2:in `send'
        from /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.14.4/lib/
active_record/transactions.rb:2
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:33:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:33:in `require'
        from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/
active_support/dependencies.rb:147:in `require'
        from /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.14.4/lib/
active_record.rb:44
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:in `require'
         ... 7 levels...
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:59:in
`require_gem'
        from ./script/../config/boot.rb:28
        from script/server:2:in `require'
        from script/server:2
[...@... ~/...]$

Any idea what the hell this is??

-Larry