Active Scaffold Error - Ruby 1.8.7

I had this same Active Scaffold problem on Ubuntu 9.04. Installing Ruby
1.8.6 instead of the default 1.8.7 was the key. I followed the
instructions in this link:

http://programmers-blog.com/2009/06/08/ruby-1-8-6-in-ubuntu-9-04-64-minimal